Skip to content

Frame Relay – basics

February 19, 2010

Auto config - using LMI and inverse arp.

active = good
inactive = remote fail
deleted = local fail

__________________________________________

!
conf  t
int s0/0
encapsulation frame-relay
ip address 10.1.1.1 255.255.255.0
no shut
!

__________________________________________

Verify

sh frame-relay lmi #status messages sent and revd and LMI type.
ping
sh frame-relay map
sh frame-relay pvc

__________________________________________
__________________________________________

Manual Config

point 2 point + multipoint (hub)

router eigrp 1
no auto-summary
network 10.1.1.1 0.255.255.255
network 172.16.0.0 0.0.255.255
network 192.168.1.0 0.0.0.255
!
conf t
int s0/0
encapsulation frame-relay
no frame-relay inverse-arp #prevents auto DLCI discovery of remote routers.
no arp frame-relay #stop others discovering your DLCI.
no ip address
!
int s0/0.102 point-to-point
ip address 10.1.1.1.255.255.255.0
frame-relay interface-dlci 102 #associates DLCI, no specific destination.
!
!
int s0/0.201 multilink
ip address 172.16.1.1 255.255.255.0
frame-relay map ip 172.16.1.2 dlci 103 broadcast #need broadcast for routing protocol
frame-relay map ip 172.16.1.3 dlci 104 broadcast
no ip split-horizon eigrp 1
!

—-

remote multilink example (spoke)

!
conf t
int s0/0
ip address 172.16.1.2 255.255.255.0
encapsulation frame-relay
no frame-relay inverse-arp
no arp frame-relay
frame-relay map ip 172.16.1.1 301 broadcast
frame-relay map ip 172.16.1.3 301 broadcast
no shutdown
!
!
!
conf t
int s0/0
ip address 172.16.1.3 255.255.255.0
encapsulation frame-relay
no frame-relay inverse-arp
no arp frame-relay
frame-relay map ip 172.16.1.1 401 broadcast
frame-relay map ip 172.16.1.2 401 broadcast
no shutdown
!

_________________________________________

Verify

sh frame-relay lmi #status messages sent and revd and LMI type.
ping
sh frame-relay map
sh frame-relay pvc

About these ads
No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: